Jump to content

Photo

Guardians Of Hyjal: Call Of The Ancients Can't Be Finished


  • Please log in to reply
2 replies to this topic

#1 14045

14045
  • Member
  • 9 posts

Posted 04 March 2018 - 06:46 AM

So as the title suggest I can't seem to finish that quest; I've assisted all of them but somehow the quest thinks I haven't assisted Aviana.

Yes I'm sure I've assisted all of them cause I can't find any more exclamation marks on the map (yes inside those portals too) except for the quest from Ysera (Last Guardian; which, at least for me, is undoable) and Finkle Einhorn which I think has got nothing do with the quest chain. Other than that I've achieved the "Coming Down the Mountain" achievement so I'm sure I've done the quest chain (since most Hyjal's quest are part of the chain)

Yes I've tried abandoning the quest and retake it to no avail.

Yes I've tried the "delete cache" method to no avail.

Yes I've tried abandoning the quest, delete cache, and retake quest to no avail.

So perhaps someone has got an explanation to this like maybe I stupidly skipped something important?

 

Thanks in advance.

*edit: I'm at Monster Realm (4.3.4)



#2 Wonderman

Wonderman

    Retired

  • Developer
  • 1710 posts
  • LocationPoland

Posted 07 March 2018 - 08:29 AM

1. Abandon and retake a quest: Guardians of Hyjal: Call of the Ancients

2. Usually players skip this: http://www.wowhead.c...odex-of-shadows

3. http://www.wowhead.c...6/thisalee-crow



#3 14045

14045
  • Member
  • 9 posts

Posted 08 March 2018 - 08:24 AM

edit: Wonderman PM'ed me, I think I'm gonna go from there