Jump to content

Photo

Bfa Launcher Problems

BFA Download Support Launcher

  • This topic is locked This topic is locked
1 reply to this topic

#1 jovannicuz

jovannicuz
  • Member
  • 1 posts

Posted 08 January 2019 - 10:07 PM

Hello, I'm currently having trouble launching the BFA launcher.
 

Retail BFA launches just fine for me and I am able to play it without trouble. I have tried all the BFA downloads.

 

Downloads:

- Put BFAClient (Torrent Magnet download option) through Torrent, and then extracted it once it finished downloading. When I open "WoW Client Launcher" a black box with Blue writing pops up. After like 3 seconds, words get written below and the box disappears. The words say something along the lines of "Object reference not set to an instance of an object"

- Downloaded the Run and Play version (MinimalBFA). Same outcome as the Client download.

- Downloaded retail WoW and tried to launch using retail WoW data with the launcher download (Patcher28153), but had the same outcome.

 

What Enchantress and I have attempted so far:

- Making the BFA files an exception in my virus protection application (Symantec Endpoint Protection). This failed as well. - Redownloaded DirectX and then restarted PC.

- Lowered my maximum processor performance from 100% to 80%

 

If you have any ideas on what could be the problem, please tell me. We are grabbing st straws now to get this to work.



#2 Enchantress

Enchantress

    Member

  • Forum Moderator
  • 23 posts

Posted 09 January 2019 - 10:27 AM

Hi there,

 

since you posted me that you managed to solve problem, Im closing this topic - and posting solution for future players with that issue:

 

Right click on "Arctium WoW Client Launcher"
Dlick "Troubleshoot Compatability"
Then click "Troubleshoot Program"
Then check mark " The Program requires additional permissions"

 

:)


hwguoj.png






Also tagged with one or more of these keywords: BFA, Download, Support, Launcher